about summary refs log tree commit diff
path: root/users/glittershark/owothia/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/owothia/shell.nix')
-rw-r--r--users/glittershark/owothia/shell.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/users/glittershark/owothia/shell.nix b/users/glittershark/owothia/shell.nix
new file mode 100644
index 0000000000..9446a353d5
--- /dev/null
+++ b/users/glittershark/owothia/shell.nix
@@ -0,0 +1,14 @@
+args@{ pkgs ? (import ../../../. {}).third_party, ... }:
+
+((import ./packageSet.nix args).extend (pkgs.haskell.lib.packageSourceOverrides {
+  owothia = pkgs.gitignoreSource ./.;
+})).shellFor {
+  packages = p: [p.owothia];
+  withHoogle = true;
+  doBenchmark = true;
+  buildInputs = with pkgs.haskellPackages; [
+    cabal-install
+    hlint
+    pkgs.haskell-language-server.ghc883
+  ];
+}