about summary refs log tree commit diff
path: root/tools/nixery/docs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/nixery/docs/default.nix')
-rw-r--r--tools/nixery/docs/default.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/tools/nixery/docs/default.nix b/tools/nixery/docs/default.nix
index 876a34dcf1..74409fcfa9 100644
--- a/tools/nixery/docs/default.nix
+++ b/tools/nixery/docs/default.nix
@@ -7,7 +7,7 @@
 # Some of the documentation is pulled in and included from other
 # sources.
 
-{ fetchFromGitHub, mdbook, runCommand, rustPlatform }:
+{ fetchFromGitHub, mdbook, runCommand, rustPlatform, postamble ? "" }:
 
 let
   nix-1p = fetchFromGitHub {
@@ -17,10 +17,14 @@ let
     sha256 = "1pf9i90gn98vz67h296w5lnwhssk62dc6pij983dff42dbci7lhj";
   };
 in
-runCommand "nixery-book" { } ''
+runCommand "nixery-book"
+{
+  POSTAMBLE = postamble;
+} ''
   mkdir -p $out
   cp -r ${./.}/* .
   chmod -R a+w src
   cp ${nix-1p}/README.md src/nix-1p.md
+  echo "''${POSTAMBLE}" >> src/nixery.md
   ${mdbook}/bin/mdbook build -d $out
 ''