about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index 1b1715cf9f..529794e596 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -25,6 +25,9 @@ let
   # through revision numbers.
   nixery-commit-hash = "depot";
 
+  # If Nixery is built outside of depot, it needs to dynamically fetch
+  # the current nix-1p.
+  nix-1p-git = builtins.fetchGit "https://code.tvl.fyi/depot.git:/nix/nix-1p.git";
 in
 depot.nix.readTree.drvTargets rec {
   # Implementation of the Nix image building logic
@@ -36,6 +39,8 @@ depot.nix.readTree.drvTargets rec {
   #
   # If the nixpkgs commit is known, append it to the main docs page.
   nixery-book = callPackage ./docs {
+    nix-1p = depot.nix.nix-1p or nix-1p-git;
+
     postamble = lib.optionalString (pkgs ? nixpkgsCommits.unstable) ''
       ### Which revision of `nixpkgs` is used for the builds?