about summary refs log tree commit diff
path: root/third_party/lisp/cl-who.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/cl-who.nix')
-rw-r--r--third_party/lisp/cl-who.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/third_party/lisp/cl-who.nix b/third_party/lisp/cl-who.nix
new file mode 100644
index 0000000000..50e4e68c03
--- /dev/null
+++ b/third_party/lisp/cl-who.nix
@@ -0,0 +1,21 @@
+{ depot, pkgs, ... }:
+
+let
+
+  src = pkgs.fetchFromGitHub {
+    owner = "edicl";
+    repo = "cl-who";
+    rev = "0d3826475133271ee8c590937136c1bc41b8cbe0";
+    sha256 = "0sc8nji9q1df04lhsiwsjy1a35996bibl31w5hp5sh8q6sa122dy";
+  };
+
+in depot.nix.buildLisp.library {
+  name = "cl-who";
+
+  srcs = map (f: src + ("/" + f)) [
+    "packages.lisp"
+    "specials.lisp"
+    "util.lisp"
+    "who.lisp"
+  ];
+}