about summary refs log tree commit diff
path: root/third_party/lisp/cffi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/cffi.nix')
-rw-r--r--third_party/lisp/cffi.nix17
1 files changed, 9 insertions, 8 deletions
diff --git a/third_party/lisp/cffi.nix b/third_party/lisp/cffi.nix
index 62c1f81da7..de1d0c2e8e 100644
--- a/third_party/lisp/cffi.nix
+++ b/third_party/lisp/cffi.nix
@@ -1,11 +1,8 @@
 # CFFI purports to be the Common Foreign Function Interface.
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
 with depot.nix;
-let src = builtins.fetchGit {
-  url = "https://github.com/cffi/cffi.git";
-  rev = "5e838bf46d0089c43ebd3ea014a207c403e29c61";
-};
+let src = with pkgs; srcOnly lispPackages.cffi;
 in buildLisp.library {
   name = "cffi";
   deps = with depot.third_party.lisp; [
@@ -13,11 +10,15 @@ in buildLisp.library {
     babel
     trivial-features
     (buildLisp.bundled "asdf")
-    (buildLisp.bundled "uiop")
   ];
 
-  srcs = map (f: src + ("/src/" + f)) [
-    "cffi-sbcl.lisp"
+  srcs = [
+    {
+      ecl = src + "/src/cffi-ecl.lisp";
+      sbcl = src + "/src/cffi-sbcl.lisp";
+      ccl = src + "/src/cffi-openmcl.lisp";
+    }
+  ] ++ map (f: src + ("/src/" + f)) [
     "package.lisp"
     "utils.lisp"
     "libraries.lisp"