about summary refs log tree commit diff
path: root/third_party/git/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/git/default.nix')
-rw-r--r--third_party/git/default.nix23
1 files changed, 8 insertions, 15 deletions
diff --git a/third_party/git/default.nix b/third_party/git/default.nix
index 10e47fea26..eed07b5616 100644
--- a/third_party/git/default.nix
+++ b/third_party/git/default.nix
@@ -1,16 +1,9 @@
-# Use the upstream git derivation (there's a lot of stuff happening in
-# there!) and just override the source:
-{ depot, ... }:
+# git with custom patches. This is also used by cgit via
+# `pkgs.srcOnly`.
+{ pkgs, ... }:
 
-with depot.third_party;
-
-(originals.git.overrideAttrs(_: {
-  version = "2.23.0";
-  src = ./.;
-  doInstallCheck = false;
-  preConfigure = ''
-    ${autoconf}/bin/autoreconf -i
-  '';
-})).override {
-  sendEmailSupport = true;
-}
+pkgs.git.overrideAttrs (old: {
+  patches = (old.patches or [ ]) ++ [
+    ./0001-feat-third_party-git-date-add-dottime-format.patch
+  ];
+})