about summary refs log tree commit diff
path: root/tests/timeout.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/timeout.nix')
-rw-r--r--tests/timeout.nix28
1 files changed, 25 insertions, 3 deletions
diff --git a/tests/timeout.nix b/tests/timeout.nix
index b41368bb38e2..540fba934ff6 100644
--- a/tests/timeout.nix
+++ b/tests/timeout.nix
@@ -1,6 +1,28 @@
 with import ./config.nix;
 
-mkDerivation {
-  name = "timeout";
-  builder = ./timeout.builder.sh;
+{
+
+  infiniteLoop = mkDerivation {
+    name = "timeout";
+    buildCommand = ''
+      echo "‘timeout’ builder entering an infinite loop"
+      while true ; do echo -n .; done
+    '';
+  };
+
+  silent = mkDerivation {
+    name = "silent";
+    buildCommand = ''
+      sleep 60
+    '';
+  };
+
+  closeLog = mkDerivation {
+    name = "silent";
+    buildCommand = ''
+      exec > /dev/null 2>&1
+      sleep 1000000000
+    '';
+  };
+
 }