about summary refs log tree commit diff
path: root/ci-builds.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ci-builds.nix')
-rw-r--r--ci-builds.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/ci-builds.nix b/ci-builds.nix
new file mode 100644
index 0000000000..46480c41a1
--- /dev/null
+++ b/ci-builds.nix
@@ -0,0 +1,18 @@
+# This file defines the derivations that should be built by CI.
+#
+# The plan is still to implement recursive tree traversal
+# automatically and detect all derivations that have `meta.enableCI =
+# true`, but this is currently more effort than it would save me.
+
+let
+  pkgs = import ./default.nix {};
+in with pkgs; [
+  ops.journaldriver
+  ops.kms_pass
+  ops.sync-gcsr
+  tools.blog_cli
+  tools.emacs
+  web.cgit-taz
+
+  # web.tazblog #  TODO(tazjin): Happstack build failure in nixos-unstable
+]