about summary refs log tree commit diff
path: root/web/atward/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-05-03T21·31+0200
committertazjin <mail@tazj.in>2021-05-03T22·55+0000
commit51b5475f40111d0a084b3ede6eec77d28b375536 (patch)
treecf28c7c2d53b755b41d5ee50a5bf1fd7285979fd /web/atward/Cargo.toml
parent35aa79d14b2f4032efd79cda2c25b11540768107 (diff)
feat(web/atward): Implement match scaffolding for TVL redirector r/2559
atward is going to be a new TVL service, living at atward.tvl.fyi,
which users can configure as a search engine in their browser.

It will understand a variety of TVL-specific query types (such as
bug/CL links or code paths). In the future it might also support
features like go-links.

This commit configures the initial setup for query matchers in atward
and adds an example query type (for bugs).

This is not yet wired up to a web server.

Change-Id: Ifaf06c3f5cc378eee7894b7576ef583fc89264f0
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3087
Tested-by: BuildkiteCI
Reviewed-by: isomer <isomer@tvl.fyi>
Diffstat (limited to 'web/atward/Cargo.toml')
-rw-r--r--web/atward/Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/web/atward/Cargo.toml b/web/atward/Cargo.toml
new file mode 100644
index 0000000000..c9d8d02c0d
--- /dev/null
+++ b/web/atward/Cargo.toml
@@ -0,0 +1,9 @@
+[package]
+name = "atward"
+version = "0.1.0"
+authors = ["Vincent Ambo <mail@tazj.in>"]
+edition = "2018"
+
+[dependencies]
+regex = "1.5"
+rouille = "3.0"