about summary refs log tree commit diff
path: root/users/glittershark/system/system/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-11-29T23·59-0500
committerglittershark <grfn@gws.fyi>2020-11-30T00·03+0000
commitd4fb573cf76ebb1651bcce711bd4cba849a1404d (patch)
tree025969daf566ce5c15dadb0227cb0b297de51fb1 /users/glittershark/system/system/default.nix
parent904cd3e6c040f7ac028c75f8a1fd7e2b1cb2b629 (diff)
feat(gs/system): Init yeren r/1962
My new work laptop, a dell XPS 13.

Change-Id: Ieab06622c9b280182025edfa63adf649e5fc70d8
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2205
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'users/glittershark/system/system/default.nix')
-rw-r--r--users/glittershark/system/system/default.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/users/glittershark/system/system/default.nix b/users/glittershark/system/system/default.nix
index 2223f33ce3..a9eb4a130a 100644
--- a/users/glittershark/system/system/default.nix
+++ b/users/glittershark/system/system/default.nix
@@ -13,12 +13,19 @@ rec {
     configuration = mugwump;
   }).system;
 
+  yeren = import ./machines/yeren.nix;
+
+  yerenSystem = (pkgs.nixos {
+    configuration = yeren;
+  }).system;
+
   iso = import ./iso.nix args;
 
   # Build chupacabra in CI
   meta.targets = [
     "chupacabraSystem"
     "mugwumpSystem"
+    "yerenSystem"
 
     "iso"
   ];