about summary refs log tree commit diff
path: root/users/Profpatsch/parked/ical-smolify/default.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2024-08-05T09·07+0200
committerProfpatsch <mail@profpatsch.de>2024-08-06T09·59+0000
commit3202d008d5ee541b984dfd4fc3b44f92a861116a (patch)
tree30dc8b308b13c6cc4182f4ee6adb787f68d3f5b3 /users/Profpatsch/parked/ical-smolify/default.nix
parent37b2c2ce7892487b1c31d6ad3f7988841014ba89 (diff)
chore(users/Profpatsch): park ical-smolify r/8446
Parked projects: I might pick these up again, but don’t want to
maintain them right now. Might delete later, or reinstate.

Change-Id: Ieb4f51dfaeba33c84820ca804b57c016e05bf566
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12137
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'users/Profpatsch/parked/ical-smolify/default.nix')
-rw-r--r--users/Profpatsch/parked/ical-smolify/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/users/Profpatsch/parked/ical-smolify/default.nix b/users/Profpatsch/parked/ical-smolify/default.nix
new file mode 100644
index 000000000000..bf766db0e974
--- /dev/null
+++ b/users/Profpatsch/parked/ical-smolify/default.nix
@@ -0,0 +1,23 @@
+{ depot, pkgs, lib, ... }:
+
+let
+  ical-smolify = pkgs.writers.writeHaskell "ical-smolify"
+    {
+      libraries = [
+        pkgs.haskellPackages.iCalendar
+        depot.users.Profpatsch.my-prelude
+        depot.users.Profpatsch.execline.exec-helpers-hs
+
+      ];
+      ghcArgs = [ "-threaded" ];
+    } ./IcalSmolify.hs;
+
+in
+
+ical-smolify.overrideAttrs (old: {
+  meta = lib.recursiveUpdate old.meta or { } {
+    # Dependency iCalendar no longer builds in nixpkgs due to a lack of maintenance upstream
+    # https://github.com/nixos/nixpkgs/commit/13d10cc6e302e7d5800c6a08c1728b14c3801e26
+    ci.skip = true;
+  };
+})