about summary refs log tree commit diff
path: root/users/Profpatsch/check-crate-advisory/default.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2023-04-08T12·17+0200
committerclbot <clbot@tvl.fyi>2023-04-08T12·25+0000
commit0d4ca2c31bd8967308ecb52306ea74ea4dde77c0 (patch)
treef2403def5ed79b2786c1b51a8ed054947aa4b1a3 /users/Profpatsch/check-crate-advisory/default.nix
parent5e400b5b2478fa59a84cc9a69c525ada4be6f0c3 (diff)
chore(users/Profpatsch): delete check-crate-advisory r/6079
Change-Id: Iefd7d8bcd699c9bef5c88e730e1d2dc5ec407ee0
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8466
Autosubmit: Profpatsch <mail@profpatsch.de>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/Profpatsch/check-crate-advisory/default.nix')
-rw-r--r--users/Profpatsch/check-crate-advisory/default.nix68
1 files changed, 0 insertions, 68 deletions
diff --git a/users/Profpatsch/check-crate-advisory/default.nix b/users/Profpatsch/check-crate-advisory/default.nix
deleted file mode 100644
index e948771e2a75..000000000000
--- a/users/Profpatsch/check-crate-advisory/default.nix
+++ /dev/null
@@ -1,68 +0,0 @@
-{ pkgs, depot, lib, ... }:
-
-let
-  bins =
-    depot.nix.getBins pkgs.s6-portable-utils [ "s6-ln" "s6-cat" "s6-echo" "s6-mkdir" "s6-test" "s6-touch" "s6-dirname" ]
-    // depot.nix.getBins pkgs.lr [ "lr" ]
-  ;
-  crate-advisories = "${depot.third_party.rustsec-advisory-db}/crates";
-
-  check-security-advisory = depot.nix.writers.rustSimple
-    {
-      name = "parse-security-advisory";
-      dependencies = [
-        depot.third_party.rust-crates.toml
-        depot.third_party.rust-crates.semver
-      ];
-    }
-    (builtins.readFile ./check-security-advisory.rs);
-
-  # $1 is the directory with advisories for crate $2 with version $3
-  check-crate-advisory = depot.nix.writeExecline "check-crate-advisory" { readNArgs = 3; } [
-    "pipeline"
-    [ bins.lr "-0" "-t" "depth == 1" "$1" ]
-    "forstdin"
-    "-0"
-    "-Eo"
-    "0"
-    "advisory"
-    "if"
-    [ depot.tools.eprintf "advisory %s\n" "$advisory" ]
-    check-security-advisory
-    "$advisory"
-    "$3"
-  ];
-
-  # Run through everything in the `crate-advisories` repository
-  # and check whether we can parse all the advisories without crashing.
-  test-parsing-all-security-advisories = depot.nix.runExecline "check-all-our-crates" { } [
-    "pipeline"
-    [ bins.lr "-0" "-t" "depth == 1" crate-advisories ]
-    "if"
-    [
-      # this will succeed as long as check-crate-advisory doesn’t `panic!()` (status 101)
-      "forstdin"
-      "-0"
-      "-E"
-      "-x"
-      "101"
-      "crate_advisories"
-      check-crate-advisory
-      "$crate_advisories"
-      "foo"
-      "0.0.0"
-    ]
-    "importas"
-    "out"
-    "out"
-    bins.s6-touch
-    "$out"
-  ];
-in
-
-depot.nix.readTree.drvTargets {
-  inherit
-    check-crate-advisory
-    test-parsing-all-security-advisories
-    ;
-}