about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
authorYureka <tvl@yuka.dev>2024-07-22T13·41+0200
committerclbot <clbot@tvl.fyi>2024-07-22T15·57+0000
commit2547ff2cf6c6e8fefa6f55e3583bea1b1d8f4263 (patch)
treedfba0f40f8bdc91136b9dd9840b6872d9dca2219 /tvix/store/Cargo.toml
parent39c8b6dece1ca414f4ce8dde49e9828e34319664 (diff)
feat(tvix/store): add grpc healthcheck service to daemon r/8403
Change-Id: Ib95fc9352a45d54f9a16c8841c7e8f7cbeeaee8c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12019
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: yuka <yuka@yuka.dev>
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index e70ed0e39674..964fc9be2e1a 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -44,6 +44,7 @@ tracing = "0.1.40"
 tracing-indicatif = "0.3.6"
 hyper-util = "0.1.6"
 toml = { version = "0.8.15", optional = true }
+tonic-health = { version = "0.12.1", default-features = false }
 
 [dependencies.tonic-reflection]
 optional = true