about summary refs log tree commit diff
path: root/tvix/glue/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2024-10-13T10·30+0300
committerclbot <clbot@tvl.fyi>2024-10-13T14·45+0000
commit4beee4cba79efda4145e84c12ecbc876f39f2134 (patch)
tree680ce25d0c475f8fc13c2290dc5db6ab053b225a /tvix/glue/Cargo.toml
parent5faf7c9d7b5fcf8fb2795b5879aece45d7c62b21 (diff)
refactor(tvix/glue): remove use of lazy_static r/8803
This is now supported in the standard library via std::sync::LazyLock, but
requires some manual shuffling around of code.

Change-Id: Ibb3be8458b8a8912ea04c9360d64c5cf914254d4
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12609
Autosubmit: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/glue/Cargo.toml')
-rw-r--r--tvix/glue/Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/tvix/glue/Cargo.toml b/tvix/glue/Cargo.toml
index 4836e1e3a5d8..5fac947125af 100644
--- a/tvix/glue/Cargo.toml
+++ b/tvix/glue/Cargo.toml
@@ -36,7 +36,6 @@ clap = { workspace = true }
 [dev-dependencies]
 criterion = { workspace = true, features = ["html_reports"] }
 hex-literal = { workspace = true }
-lazy_static = { workspace = true }
 mimalloc = { workspace = true }
 nix = { workspace = true, features = ["fs"] }
 pretty_assertions = { workspace = true }