about summary refs log tree commit diff
path: root/tvix/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-10-13T16·09+0300
committerflokli <flokli@flokli.de>2024-10-17T22·15+0000
commit1c80bc4b5b2736e9421fc8a6f833f1e592e08642 (patch)
treea4d58eec75f230bbf559933a85d19c25ed35e8b7 /tvix/Cargo.toml
parentf0d594789ee01df43de50198adef91a11e2a355a (diff)
refactor(tvix/store): remove use of lazy_static r/8825
This is now supported in the standard library via std::sync::LazyLock,
but requires some manual shuffling around of code.

Change-Id: Ifca792f4d2dbc36b703de4a4dfa406015ab86da7
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12614
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: flokli <flokli@flokli.de>
Reviewed-by: edef <edef@edef.eu>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.toml')
-rw-r--r--tvix/Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/tvix/Cargo.toml b/tvix/Cargo.toml
index e86ae3a8f93a..6b30e1196c39 100644
--- a/tvix/Cargo.toml
+++ b/tvix/Cargo.toml
@@ -77,7 +77,6 @@ http = "1.1.0"
 hyper-util = "0.1.7"
 indicatif = "0.17.8"
 itertools = "0.12.1"
-lazy_static = "1.5.0"
 lexical-core = "0.8.5"
 libc = "0.2.158"
 lru = "0.12.4"