about summary refs log tree commit diff
path: root/tvix/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-09-25T20·05+0200
committerclbot <clbot@tvl.fyi>2024-09-30T10·04+0000
commit2e4a373a040b5e8355d05b8030341494d1ff386b (patch)
tree3ff8d03b83f7d37d1895e2d7efb0aab28da478d1 /tvix/Cargo.toml
parent16a3b9012501ba9ad87e7e4dc6ff5e0792ea165d (diff)
feat(tvix/nar-bridge): implement range request for NARs r/8737
With an implementation of AsyncRead + AsyncSeek, axum-range can answer
range requests.

We only use it if a range has been requested, as it uses more memory
than the linear variant.

Change-Id: I0072b0a09b328f3e932f14567a2caa3a49abcbf7
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12509
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Reviewed-by: yuka <yuka@yuka.dev>
Diffstat (limited to 'tvix/Cargo.toml')
-rw-r--r--tvix/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/tvix/Cargo.toml b/tvix/Cargo.toml
index 16bf9c2dd99c..bcb8e6f7e78e 100644
--- a/tvix/Cargo.toml
+++ b/tvix/Cargo.toml
@@ -46,6 +46,8 @@ async-process = "2.2.4"
 async-stream = "0.3.5"
 async-tempfile = "0.4.0"
 axum = "0.7.5"
+axum-extra = "0.9.3"
+axum-range = "0.4.0"
 # https://github.com/liufuyang/bigtable_rs/pull/86
 bigtable_rs = { git = "https://github.com/liufuyang/bigtable_rs", rev = "1818355a5373a5bc2c84287e3a4e3807154ac8ef" }
 bitflags = "2.6.0"