about summary refs log tree commit diff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2005-01-28T20·36+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2005-01-28T20·36+0000
commita7668411a10c79ad40c9c18caf2570d5c9f52182 (patch)
treeeb4ea7eda7ac760e4933aba439bebb08b9ba2a71 /tests/Makefile.am
parent22cfdfa2460921a282fc924cce5fb26378b9fc9d (diff)
* Add a test to check whether concurrent garbage collection (i.e.,
  running the collector while builds are in progress) works
  correctly.  The test currently fails.

Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f58dfa48608c..53ecfe1fb7d7 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -34,10 +34,11 @@ fallback.sh: fallback.nix
 nix-push.sh: dependencies.nix
 nix-pull.sh: dependencies.nix
 gc.sh: dependencies.nix
+gc-concurrent.sh: gc-concurrent.nix
 
 TESTS = init.sh hash.sh lang.sh simple.sh dependencies.sh locking.sh parallel.sh \
   build-hook.sh substitutes.sh substitutes2.sh fallback.sh nix-push.sh gc.sh \
-  verify.sh nix-pull.sh
+  gc-concurrent.sh verify.sh nix-pull.sh
 
 XFAIL_TESTS =
 
@@ -54,5 +55,6 @@ EXTRA_DIST = $(TESTS) \
   build-hook.nix.in build-hook.hook.sh \
   substitutes.nix.in substituter.sh \
   substitutes2.nix.in substituter2.sh \
+  gc-concurrent.nix.in gc-concurrent.builder.sh \
   fallback.nix.in \
   $(wildcard lang/*.nix) $(wildcard lang/*.exp)