about summary refs log tree commit diff
path: root/ops/nixos/paroxysm.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-11T20·50+0200
committertazjin <mail@tazj.in>2021-04-11T22·18+0000
commit90281c4eac4cd25045ed80c5f8f27c74898a02b3 (patch)
tree804425642af16b9e299d469ad6e21c6a23a400e9 /ops/nixos/paroxysm.nix
parent7deabb8c8d6f4c7e58e2b16548b8a1895795963b (diff)
refactor(ops): Split //ops/nixos into different locations r/2482
Splits //ops/nixos into:

* //ops/nixos.nix - utility functions for building systems
* //ops/machines - shared machine definitions (read by readTree)
* //ops/modules - shared NixOS modules (skipped by readTree)

This simplifies working with the configuration fixpoint in whitby, and
is overall a bit more in line with how NixOS systems in user folders
currently work.

Change-Id: I1322ec5cc76c0207c099c05d44828a3df0b3ffc1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2931
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'ops/nixos/paroxysm.nix')
-rw-r--r--ops/nixos/paroxysm.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/ops/nixos/paroxysm.nix b/ops/nixos/paroxysm.nix
deleted file mode 100644
index cd9cd3866e47..000000000000
--- a/ops/nixos/paroxysm.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-{ depot, config, lib, pkgs, ... }:
-
-let
-  cfg = config.services.depot.paroxysm;
-  description = "TVL's majestic IRC bot";
-in {
-  options.services.depot.paroxysm.enable = lib.mkEnableOption description;
-
-  config = lib.mkIf cfg.enable {
-    systemd.services.paroxysm = {
-      inherit description;
-      script = "${depot.fun.paroxysm}/bin/paroxysm";
-      wantedBy = [ "multi-user.target" ];
-
-      environment = {
-        PARX_DATABASE_URL = "postgresql://tvldb:tvldb@localhost/tvldb";
-        PARX_IRC_CONFIG_PATH = "/var/lib/paroxysm/irc.toml";
-      };
-
-      serviceConfig = {
-        DynamicUser = true;
-        StateDirectory = "paroxysm";
-        Restart = "always";
-      };
-    };
-  };
-}