about summary refs log tree commit diff
path: root/nix/configuration.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2018-01-01T22·20+0100
committerVincent Ambo <tazjin@gmail.com>2018-01-01T22·20+0100
commita646f94d4702ddb27f07c1a23ae683278d205997 (patch)
tree27c1ec73656505374e76c4266b015db12682db16 /nix/configuration.nix
parent93681178132e8f6e6cb112f601bf4b220355bb86 (diff)
feat(nix): Add initial Tazblog Nix deployment configuration
Diffstat (limited to 'nix/configuration.nix')
-rw-r--r--nix/configuration.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/nix/configuration.nix b/nix/configuration.nix
new file mode 100644
index 000000000000..7e9949ad79ef
--- /dev/null
+++ b/nix/configuration.nix
@@ -0,0 +1,37 @@
+# This file contains basic configuration for all *.tazj.in Nix machines.
+
+{ config, pkgs, ... }:
+
+{
+  boot.loader.grub.enable = true;
+  boot.loader.grub.version = 2;
+  boot.loader.grub.device = "/dev/sda";
+
+  time.timeZone = "Europe/Oslo";
+
+  environment.systemPackages = with pkgs; [
+    curl emacs htop
+  ];
+
+
+  services.openssh.enable = true;
+
+  networking.firewall.allowedTCPPorts = [ 22 ];
+
+  users.extraUsers.vincent = {
+    isNormalUser = true;
+    uid = 1000;
+    extraGroups = [ "wheel" ];
+  };
+
+  security.sudo = {
+    enable = true;
+    extraConfig = "%wheel ALL=(ALL) NOPASSWD: ALL";
+  };
+
+  # This value determines the NixOS release with which your system is to be
+  # compatible, in order to avoid breaking some software such as database
+  # servers. You should change this only after NixOS release notes say you
+  # should.
+  system.stateVersion = "17.09"; # Did you read the comment?
+}