about summary refs log tree commit diff
path: root/ci-builds.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-20T20·37+0000
committerVincent Ambo <tazjin@google.com>2019-12-20T20·37+0000
commit8de5d093d8e35b2492c81015dcfcb052d2718614 (patch)
treef4bb5763a39c7059537fc7877e3c0ac15a4d8f69 /ci-builds.nix
parent03bfe08e1dd9faf48b06cb146bfa446575cde88a (diff)
refactor: Fix a variety of filepaths for repo relayouting r/238
This fixes readTree and the various project builds, as well
as (hopefully) most documentation links inside of the projects.
Diffstat (limited to 'ci-builds.nix')
-rw-r--r--ci-builds.nix20
1 files changed, 10 insertions, 10 deletions
diff --git a/ci-builds.nix b/ci-builds.nix
index 5ffc14e318..46480c41a1 100644
--- a/ci-builds.nix
+++ b/ci-builds.nix
@@ -1,18 +1,18 @@
-# This file is invoked by the CI build and recursively filters the
-# package set for attributes that should be built automatically.
+# This file defines the derivations that should be built by CI.
 #
-# Packages can be opted-in to being built by CI by setting
-# `meta.enableCI = true`.
-#
-# TODO(tazjin): Actually implement the above.
+# The plan is still to implement recursive tree traversal
+# automatically and detect all derivations that have `meta.enableCI =
+# true`, but this is currently more effort than it would save me.
 
 let
   pkgs = import ./default.nix {};
 in with pkgs; [
-  services.nixcon-demo
-  services.tazblog
+  ops.journaldriver
+  ops.kms_pass
+  ops.sync-gcsr
   tools.blog_cli
   tools.emacs
-  tools.kms_pass
-]
+  web.cgit-taz
 
+  # web.tazblog #  TODO(tazjin): Happstack build failure in nixos-unstable
+]