about summary refs log tree commit diff
path: root/ci-builds.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-21T22·59-0400
committerglittershark <grfn@gws.fyi>2020-07-23T19·47+0000
commitfa01f515e278d3b8d0c8af20d0668fb7baa98d6a (patch)
tree5d2e1b8eebd89a3dbe3ba75b7a151d6623179d6c /ci-builds.nix
parent37cc98d0780a6569962e8a1f16ba3d96fdd1c164 (diff)
feat(web/panettone): The start of a very simple issue tracker r/1433
Initial commit for Panettone, a very simple issue tracker for TVL. In
its current state this launches a web server with authenticates with our
ldap server, and supports listing and creating issues via static html
pages and simple forms.

We've been needing an issue tracker for a while now, but none of the
options out there seem very good - or there are some good ones, but
they're AGPL licensed and we don't want to deal with them. Rather than
muck around with Trac or Bugzilla, we've decided to write our own.

Change-Id: I704f0996d15199329bbd5450f3d959046bf13973
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1337
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'ci-builds.nix')
-rw-r--r--ci-builds.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/ci-builds.nix b/ci-builds.nix
index 19723e4b30..921b6f335f 100644
--- a/ci-builds.nix
+++ b/ci-builds.nix
@@ -67,8 +67,12 @@ in lib.fix (self: {
     rapidcheck
   ] ++ builtins.attrValues lisp;
 
+  lisp = with depot.lisp; [
+    dns
+    klatre
+  ];
+
   various = with depot; [
-    lisp.dns
     nix.buildLisp.example
     nix.yants.tests
     tools.cheddar
@@ -76,6 +80,7 @@ in lib.fix (self: {
     web.cgit-taz
     web.todolist
     web.tvl
+    web.panettone
     (drvify "getBins-tests" nix.getBins.tests)
   ]
   ++ nix.runExecline.tests