about summary refs log tree commit diff
path: root/ci-builds.nix
diff options
context:
space:
mode:
authorLuke Granger-Brown <hg@lukegb.com>2020-07-26T12·51+0100
committerlukegb <lukegb@tvl.fyi>2020-07-27T00·00+0000
commite780435d09207b84dff49c870e875ad3f052b2fe (patch)
treebf219d90d330f186eca378ea63e7d0b88d4aed74 /ci-builds.nix
parent2b7fe6f95769a134f55f277f7d5575530467babd (diff)
chore(3p/gerrit_plugins): add machinery for compiling Gerrit plugins from source r/1488
This looks particularly obnoxious for the owners plugin, because it's
actually two plugins with a common library in the same repo. Other
plugins are much cleaner to deal with (hence the default for
overlayPluginCmd).

Change-Id: Ibb9588c8a29b63e8509436fcbb70054e89349712
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1461
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'ci-builds.nix')
-rw-r--r--ci-builds.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/ci-builds.nix b/ci-builds.nix
index d4ea63d99e..6b7f48f44d 100644
--- a/ci-builds.nix
+++ b/ci-builds.nix
@@ -68,6 +68,11 @@ in lib.fix (self: {
     rapidcheck
   ] ++ builtins.attrValues lisp;
 
+  gerrit = with depot.third_party.gerrit_plugins; [
+    depot.third_party.gerrit
+    owners
+  ];
+
   lisp = with depot.lisp; [
     dns
     klatre