about summary refs log tree commit diff
path: root/ci-builds.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-02-21T12·48+0000
committerVincent Ambo <tazjin@google.com>2020-02-21T13·54+0000
commitf2235ba0aed43ad7a161d83b744e26b5acda3c85 (patch)
treee2ba327e52522013886217c02b3e6d32c467fa6b /ci-builds.nix
parent4bbbb58cb537014dd8b0b3c3c560c039ac57ad89 (diff)
feat(build): Add //fun and //ops/nixos projects to CI builds r/560
Diffstat (limited to 'ci-builds.nix')
-rw-r--r--ci-builds.nix21
1 files changed, 13 insertions, 8 deletions
diff --git a/ci-builds.nix b/ci-builds.nix
index 43ec5cef2f..624f4893b9 100644
--- a/ci-builds.nix
+++ b/ci-builds.nix
@@ -4,24 +4,29 @@
 # automatically and detect all derivations that have `meta.enableCI =
 # true`, but this is currently more effort than it would save me.
 
-let
-  pkgs = import ./default.nix {};
-in with pkgs; [
+with (import ./default.nix {}); [
+  fun.amsterdump
   fun.gemma
+  fun.quinistry
+  fun.watchblob
+  fun.wcl
+  lisp.dns
+  nix.buildLisp.example
   nix.yants.tests
   ops."posix_mq.rs"
   ops.journaldriver
   ops.kms_pass
   ops.kontemplate
   ops.mq_cli
+  ops.nixos.camdenSystem
+  ops.nixos.nuggetSystem
   ops.sync-gcsr
-  tools.cheddar
-  tools.emacs
-  web.blog
-  web.cgit-taz
-  lisp.dns
   third_party.cgit
   third_party.git
   third_party.guile
   third_party.lisp # will build all third-party libraries
+  tools.cheddar
+  tools.emacs
+  web.blog
+  web.cgit-taz
 ]