about summary refs log tree commit diff
path: root/ci-builds.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-09T10·58+0000
committerVincent Ambo <tazjin@google.com>2019-12-09T10·58+0000
commite9431682b2da6fc5085961e42b654bb8b833b879 (patch)
treea5cbac7bffbbc5a777b4a2dd9eb895cf76ac94a3 /ci-builds.nix
parenta1ac598fa0782e22c9fb9c27719a50e543757f41 (diff)
refactor: Move CI setup to separate Nix file r/111
Instead of polluting the repository namespace with the list of CI
projects, move that to a separate file.

Currently the list of projects to be built by CI is still hardcoded,
but this will be fixed soon.
Diffstat (limited to 'ci-builds.nix')
-rw-r--r--ci-builds.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/ci-builds.nix b/ci-builds.nix
new file mode 100644
index 0000000000..916317ea56
--- /dev/null
+++ b/ci-builds.nix
@@ -0,0 +1,17 @@
+# This file is invoked by the CI build and recursively filters the
+# package set for attributes that should be built automatically.
+#
+# Packages can be opted-in to being built by CI by setting
+# `meta.enableCI = true`.
+#
+# TODO(tazjin): Actually implement the above.
+
+let
+  pkgs = import ./default.nix;
+in with pkgs; [
+  services.tazblog
+  services.nixcon-demo
+  tools.kms_pass
+  tools.blog_cli
+]
+