about summary refs log tree commit diff
path: root/ci-builds.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-07-01T17·44+0100
committertazjin <mail@tazj.in>2020-07-01T19·10+0000
commit6f5211bba84bdaea391603e8aabbe304a79dd08b (patch)
tree4f0b875c8c7c232326a176f1aee2efc91b1376ba /ci-builds.nix
parentff4918b343d03cd9c60faec80d53ed8f73d11706 (diff)
chore(ci-builds): Move third_party builds to their own package group r/1147
... and remove a package that doesn't exist anymore (at this location)
from the nixpkgs allowlist.

Change-Id: I663c84c387fb04bb3b47448132ad768ed5352474
Reviewed-on: https://cl.tvl.fyi/c/depot/+/829
Reviewed-by: BuildkiteCI
Reviewed-by: isomer <isomer@tvl.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'ci-builds.nix')
-rw-r--r--ci-builds.nix17
1 files changed, 8 insertions, 9 deletions
diff --git a/ci-builds.nix b/ci-builds.nix
index 1805972c9c..076c642584 100644
--- a/ci-builds.nix
+++ b/ci-builds.nix
@@ -51,14 +51,6 @@ in lib.fix (self: {
     wcl
   ];
 
-  gitAndFriends = with depot; [
-    third_party.cgit
-    third_party.git
-    web.cgit-taz
-  ];
-
-  nix = [ depot.third_party.nix ];
-
   ops = with depot.ops; [
     depot.ops."posix_mq.rs"
     besadii
@@ -67,13 +59,20 @@ in lib.fix (self: {
     mq_cli
   ];
 
+  third_party = with depot.third_party; [
+    cgit
+    git
+    nix
+  ];
+
   various = with depot; [
-    depot.web.tvl
     lisp.dns
     nix.buildLisp.example
     nix.yants.tests
     tools.cheddar
     tools.nsfv-setup
+    web.cgit-taz
+    web.tvl
     (drvify "getBins-tests" nix.getBins.tests)
   ]
   ++ nix.runExecline.tests