about summary refs log tree commit diff
path: root/absl/status/CMakeLists.txt
diff options
context:
space:
mode:
authorXiaoyi Zhang <zhangxy@google.com>2020-02-21T16·05+0000
committerGerrit Code Review <noreply-gerritcodereview@google.com>2020-02-21T16·05+0000
commit2a5633fc077a58528cdbfe78720f3f6bfdc6044d (patch)
tree36175e9725b2e6cc65230983925e692abdbd6b9c /absl/status/CMakeLists.txt
parentf9b3d6e493c1b6ab3dbdab71c5f8fa849db4abaf (diff)
parent914ff44510505f209d8e85a01e31f4c5fb1b6a5b (diff)
Merge "Export of internal Abseil changes"
Diffstat (limited to 'absl/status/CMakeLists.txt')
-rw-r--r--absl/status/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/absl/status/CMakeLists.txt b/absl/status/CMakeLists.txt
new file mode 100644
index 000000000000..4f553867ac05
--- /dev/null
+++ b/absl/status/CMakeLists.txt
@@ -0,0 +1,52 @@
+#
+# Copyright 2020 The Abseil Authors.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#      https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+absl_cc_library(
+  NAME
+    status
+  HDRS
+    "status.h"
+  SRCS
+    "status.cc"
+    "status_payload_printer.h"
+    "status_payload_printer.cc"
+  COPTS
+    ${ABSL_DEFAULT_COPTS}
+  DEPS
+    absl::config
+    absl::core_headers
+    absl::raw_logging_internal
+    absl::inlined_vector
+    absl::stacktrace
+    absl::symbolize
+    absl::strings
+    absl::cord
+    absl::str_format
+    absl::optional
+  PUBLIC
+)
+
+absl_cc_test(
+  NAME
+    status_test
+  HDRS
+   "status_test.cc"
+  COPTS
+    ${ABSL_TEST_COPTS}
+  DEPS
+    absl::status
+    absl::strings
+    gmock_main
+)